Blog of Khlebalin Dmitriy

(Записки из мира IT…)

Первоначальная настройка Cisco Catalist 2950.


Как говорят в народе:  Дела идут, контора пишет.

Постепенно и у нас начались движения по приведению сети компании к нормальному виду. Постепенно все филиалы будут завязаны в единую локальную сеть, будут установлены нормальные коммутаторы, в нашем случае это Cisco Catalyst 2950.

Соответственно сегодня о первоначальной настройке данной железки:

в Windows можно использовать Hiper Terminal для подключения к com порту

1. Зададим пароль на enable режим

Switch> enable

Switch# configure terminal

Switch(config)# enable password my-secret-password

2. Установим пароль для входа по telnet

Switch(config)# line vty 0 15

Switch(config-line)#password my-telnet-password

3. Сразу разрешим вход по telnet

Switch(config-line)# login

Switch(config)# exit

4. Зашифруем пароли, чтобы по sh run они не показывались в открытом виде

Switch(config)# service password-encryption

5. Зададим имя девайсу, например c2950

Switch(config)# hostname c2950

6. присвоим IP-адрес нашему девайсу (в некоторых управляемых коммутаторах, ip уже присутствует по умолчанию, какой он? Обычно прописано в мануале).

c2950(config)# interface vlan 1

c2950(config-if)# ip address 192.168.1.2 255.255.255.0

c2950(config-if)# exit

7. Если вы ошибетесь при наборе чего либо в консоле, то циска начнет пытаться это отрезолвить, чем заставляет вас ждать, выключим эту фичу

c2950(config)# no ip domain-lookup

8. Зададим имя домена

c2950(config)# ip domain-name my-domain.ru

9. Зададим IP-адрес DNS сервера

c2950(config)# ip name-server 192.168.1.15

10. Зададим время

если у вас есть доступный NTP сервер (в моем случае это контроллер домена, но в последствии планируем сделать отдельный NTP сервер).

c2950(config)# ntp server 192.168.10.1 version 2 source vlan 1

c2950(config)# ntp clock-period 36029056

c2950(config)# ntp max-associations 1

где 192.168.10.1 — это IP-адрес NTP сервера

а используя «добавку» source vlan вы можете четко задать номер vlan с IP которого будет отправляться NTP запрос

если нет NTP сервера, то можно задать время вручную, но для этого придется выйти из режима конфигурирования

c2950(config)# exit

c2950# clock set 20:00:50 23 Aug 2008

11. Зададим переход с зимнего на летнее время и наоборот

c2950# configure terminal

c2950(config)# clock timezone MSK 3

c2950(config)# clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00

12. Сделаем так, чтобы по команде show logging отображалось нормальное время, а не кол-во дней и т.п.

c2950(config)# service timestamps log datetime localtime

13. Зададим дефолтовые настройки сразу всем портам на девайсе (у меня catalyst 24 порта + 4 SFP)

c2950(config)# interface range gi 0/1 — 28

c2950(config-if-range)# description not_used

c2950(config-if-range)# shutdown

c2950(config-if-range)# no cdp enable

c2950(config-if-range)# switchport nonegotiate

c2950(config-if-range)# switchport mode access

c2950(config-if-range)# exit

Рекомендую: все неиспользуемые порты держать выключенными, а ещё лучше создать влан (например 10) и все выключенные порты переместить в него:

c2950(config)# vlan 10

c2950(config-vlan)# name unused_ports

c2950(config-vlan)# shutdown

c2950(config-vlan)# exit

c2950(config)# interface range gi 0/1 — 28

c2950(config-if-range)# description not_used

c2950(config-if-range)# shutdown

c2950(config-if-range)# no cdp enable

c2950(config-if-range)# switchport nonegotiate

c2950(config-if-range)# switchport access vlan 10

c2950(config-if-range)# switchport mode access

c2950(config-if-range)# exit

14. Выключим web-интерфейс, командная строка это конечно не плохо, так скажет любой уважающий себя цисковод, но иногда нет времени сидеть и вспоминать команды командной строки, просто бывает нужно быстро зайти включить порт или еще что нибудь поправить, по любому эта функция не помешает).

c2950(config)# no ip http server

15. Зададим gateway по умолчанию (допустим это будет 192.168.1.1, т.к. мы присвоили девайсу IP 192.168.1.2/255.255.255.0)

c2950(config)# ip default-gateway 192.168.1.1

16. Если этот свич будет поддерживать маршрутизацию (будет router`ом), то включим функцию маршрутизации (если это позволяет сам девайс и его прошивка)

c2950(config)# ip routing

c2950(config)# ip classless

c2950(config)# ip subnet-zero

17. Если вы выполнили пункт 16-ть, то снова необходимо задать gateway по умолчанию, но уже другой командой

c2950(config)# ip route 0.0.0.0 0.0.0.0 192.168.1.1

18. Настроим access-list для доступа к свичу только с определенных IP-адресов

c2950(config)# ip access-list standard TELNET

c2950(config-std-nacl)# permit 192.168.1.1

c2950(config-std-nacl)# permit 192.168.1.15

c2950(config-std-nacl)# exit

19. Применим этот access-list

c2950(config)# line vty 0 15

c2950(config-line)# access-class TELNET in

20. Зададим timeout неактивности telnet сессии, по истечении указанного времени, если вы в консольке ничего не вводили, то telnet соединение будет автоматически закрываться (вообще telnet это не самый лучший вариант, конечно более безопасен SSH, но об этом чуть позже).

c2950(config-line)# exec-timeout 5 0

c2950(config-line)# exit

21. Включим SNMP, но только read only (RO) и доступность только с хоста 192.168.1.1

c2950(config)# snmp-server community RO-MY-COMPANY-NAME RO

c2950(config)# snmp-server trap-source Vlan1

c2950(config)# snmp-server source-interface informs Vlan1

c2950(config)# snmp-server location SWITCH-LOCATION

c2950(config)# snmp-server contact my-email@my-domain.ru

c2950(config)# snmp-server host 192.168.1.1 RO-MY-COMPANY-NAME

c2950(config)# exit

22. Далее сохраним конфиг

c2950# copy running-config startup-config

или вот так

c2950# wri

Подробнее инфу можно найти здесь: www.cisco.com

23. Если необходимо включить на девайсе ssh, чтобы подключаться к cisco по ssh (если это позволяет установленный IOS), то выполним следующее:

а) Обязательно указываем имя домена (необходимо для генерации ключа) см. пункт 8.

б) cisco(config)# crypto key generate rsa

в) cisco(config)# line vty 0 15

г) cisco(config)# transport preferred none

д) cisco(config)# transport input ssh

е) cisco(config)#transport output ssh

Подробнее по настройке ssh: Configuring Secure Shell on Routers and Switches Running Cisco IOS

Всем хорошей работы…

Реклама

15.11.2012 - Posted by | Network and Wi-fi cisco, huawei, tp-link, d-link, zyxel и другое...

Sorry, the comment form is closed at this time.

%d такие блоггеры, как: