Blog of Khlebalin Dmitriy

(Дорогу осилит идущий…)

Switching: VLAN, Trunk, Access.

Ранее я уже писал про базовую настройку коммутатора и маршрутизатора Cisco, не буду заострять на этом внимание. Можно потихоньку начать их соединять…

Для тех, кому данные аббревиатуры еще неизвестны, рекомендую зачитать:

http://xgu.ru/wiki/VLAN

http://xgu.ru/wiki/Native_VLAN

http://xgu.ru/wiki/Port_security

sw1# sh ip int

sw1# sh ip int br

Создадим VLANы и Access порты:

vIOS-L2-01(config)#hostname sw1

sw1(config)#vlan 10

sw1(config-vlan)#name IT

sw1(config-vlan)#exit

sw1(config)#vlan 20

sw1(config-vlan)#name USERS

sw1(config-vlan)#ex

sw1(config)#

Настроим  акцесс порты:

sw1(config)#interface gigabitEthernet 0/0

## если необходима группа портов

## sw1(config)#interface  range gigabitEthernet 0/1-10

sw1(config-if)#switchport mode access

sw1(config-if)#switchport access vlan 10

sw1(config-if)#ex

sw1(config)#interface gigabitEthernet 0/1

sw1(config-if)#switchport mode access

sw1(config-if)#switchport access vlan 20

sw1(config-if)#ex

sw1(config)# do wr

sw1# sh vlan

sw1#show vlan brief

sw1# sh interfaces gig 0/1

sw1#show interfaces switchport

Аналогично сделаем тоже самое на втором коммутаторе.

Запингуем с компьютера 10.0.0.1 остальные компы.

Создадим транк между коммутаторами:

sw1(config)#interface gigabitEthernet 1/3

sw1(config-if)#switchport mode trunk

Command rejected: An interface whose trunk encapsulation is «Auto» can not be configured to «trunk» mode.

sw1(config-if)#

##некоторые коммутаторы или прошивки требуют явного указания инкапсуляции

sw1(config-if)#switchport trunk encapsulation dot1q

sw1(config-if)#switchport mode trunk

## если явно необходимо разрешить определенные VLANы в транке

##sw1(config-if)#switchport trunk allowed vlan 10,20

sw1(config-if)#ex

sw1(config)#exit

sw1#show interface gigabitEthernet 1/3 switchport

Аналогично сделаем на втором коммутаторе.

sw2#show interfaces trunk

Теперь видим, что с  10.0.0.1 пингуется 10.0.0.3 VLAN 10, тоже самое c VLAN 20.

Если необходимо, можем еще настроить управляющий VLAN (обычно делаю VLAN 2) на обоих коммутаторах.

sw1(config)#vlan 2

sw1(config-vlan)#name manage

sw1(config-vlan)#ex

sw1(config)#interface vlan 2

sw1(config-if)#ip address 10.0.2.1 255.255.255.0

sw1(config-if)#no shutdown

sw1(config-if)#

*May 22 13:20:19.232: %LINK-3-UPDOWN: Interface Vlan2, changed state to up

*May 22 13:20:20.232: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to up

sw1(config-if)#ex

sw1(config)#exit

sw1#wr

Аналогично на втором коммутаторе.

Коммутаторы видят друг друга, компы в нужных VLANах тоже, что и требовалось на данном этапе.

Продолжение следует…

Всем хорошей работы!!!

28.05.2019 Posted by | Network and Wi-fi: cisco, mikrotik, huawei, tp-link, d-link, zyxel и другое... | Комментарии к записи Switching: VLAN, Trunk, Access. отключены