Blog of Khlebalin Dmitriy

(Дорогу осилит идущий…)

Switching: L3 VLAN Routing.


Недавно я писал про L2 layer коммутаторы. Добавим в цепочку коммутатор L3 и смаршрутизируем VLANы.

Добавим в схему коммутатор L3. С L3 коммутатором в GNS у меня как-то не сложилось-сначала шаблон никак не хотел заводиться, но спустя пару часов плясок он в итоге завелся, пару дней поработал и снова «воткнул». Пришлось его снова пересоздать, хотя никаких предпосылок для падения не было.

Ну это все лирика и баги GNS3.

Немного изменим схему и ip адреса для наглядности:

На этом коммутаторе L3 VLANы создаются несколько иначе (возможно это напрямую зависит от прошивки).

ESW1(config)#hostname sw3

sw3(config)#do sh ip int br

sw3#vlan database

sw3(vlan)#vlan 2

VLAN 2 added:

Name: VLAN0002

sw3(vlan)#vlan 10

VLAN 10 added:

Name: VLAN0010

sw3(vlan)#vlan 20

VLAN 20 added:

Name: VLAN0020

sw3(vlan)#exit

APPLY completed.

Exiting….

sw3#

Сразу настроим управляющий VLAN:

sw3(config)#interface vlan 2

sw3(config-if)#ip address 10.0.2.3 255.255.255.0

sw3(config-if)#no shutdown

sw3(config-if)#ex

sw3(config)#exit

Настроим транки к обоим коммутаторам.

sw3(config)#interface fastEthernet 0/0

sw3(config-if)#switchport trunk encapsulation dot1q

sw3(config-if)#switchport mode trunk

sw3(config-if)#no shutdown

sw3(config-if)#

*Mar  1 00:49:17.275: %DTP-5-TRUNKPORTON: Port Fa0/0 has become dot1q trunk

sw3(config-if)#ex

*Mar  1 00:49:19.739: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

sw3(config-if)#ex

*Mar  1 00:49:47.867: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to up

sw3(config)#interface fastEthernet 0/1

sw3(config-if)#switchport trunk encapsulation dot1q

sw3(config-if)#switchport mode trunk

sw3(config-if)#no shutdown

sw3(config-if)#

*Mar  1 00:53:25.559: %DTP-5-TRUNKPORTON: Port Fa0/1 has become dot1q trunk

sw3(config-if)#

*Mar  1 00:53:28.015: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

sw3(config-if)#ex

sw3(config)#

sw3#show interfaces trunk

Также видим, что с sw1 в VLAN 2 у нас доступен sw3:

Зададим ip адреса в 10 и 20 вланах (это больше для наглядности):

sw3(config)#interface vlan 10

sw3(config-if)#i

*Mar  1 01:03:08.727: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

sw3(config-if)#ip address 10.0.10.5 255.255.255.0

sw3(config-if)#no shutdown

sw3(config-if)#ex

 

sw3(config)#interface vlan 20

sw3(config-if)#i

*Mar  1 01:03:08.727: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

sw3(config-if)#ip address 10.0.20.6 255.255.255.0

sw3(config-if)#no shutdown

sw3(config-if)#ex

Добавим маршрутизацию vlan-ов:

sw3 (config)# ip routing

sw3#sh ip route

Всем хорошей работы!!!

 

20.06.2019 - Posted by | Network and Wi-fi: cisco, mikrotik, huawei, tp-link, d-link, zyxel и другое...

1 комментарий

  1. […] снова про Cisco. В прошлый раз рассмотрели VLAN Routing на L3 коммутаторе, но если такового нет, то будет полезен […]

    Уведомление от InterVLAN Routing на маршрутизаторе Cisco. « Blog of Khlebalin Dmitriy | 25.06.2019


Sorry, the comment form is closed at this time.

%d такие блоггеры, как: