Blog of Khlebalin Dmitriy

(Дорогу осилит идущий…)

InterVLAN Routing на маршрутизаторе Cisco.


Сегодня снова про Cisco. В прошлый раз писал про VLAN Routing на L3 коммутаторе, но если такового нет, то будет полезен маршрутизатор.

Для понимания процесса нам снова сюда: http://xgu.ru/wiki/VLAN_%D0%B2_Cisco

Сконфигурим рабочие станции (GNS3):

Создадим VLANы и Access порты:

vIOS-L2-01(config)#hostname sw1

sw1(config)#vlan 10

sw1(config-vlan)#name IT

sw1(config-vlan)#exit

sw1(config)#vlan 20

sw1(config-vlan)#name USERS

sw1(config-vlan)#ex

sw1(config)#

Настроим порты:

sw1(config)#interface gigabitEthernet 0/0

## если необходима группа портов

## sw1(config)#interface  range gigabitEthernet 0/1-10

sw1(config-if)#switchport mode access

sw1(config-if)#switchport access vlan 10

sw1(config-if)#ex

sw1(config)#interface gigabitEthernet 0/1

sw1(config-if)#switchport mode access

sw1(config-if)#switchport access vlan 20

sw1(config-if)#ex

sw1(config)# do wr

sw1# sh vlan br

Перейдем к настройке роутера:

R1(config)#interface fastEthernet 0/0

R1(config-if)#no ip address

R1(config-if)#no shutdown

R1(config-if)#

*Mar  1 00:56:08.699: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

*Mar  1 00:56:09.699: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface fa0/0.10

R1(config-subif)#encapsulation dot1q 10

R1(config-subif)#

*Mar  1 00:56:55.967: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

R1(config-subif)#ip address 10.0.0.100 255.0.0.0

R1(config-subif)#exit

R1(config)#interface fa0/0.20

R1(config-subif)#encapsulation dot1q 20

R1(config-subif)#ip address 20.0.0.100 255.0.0.0

R1(config-subif)#exit

R1(config)#router rip

R1(config-router)#network 10.0.0.0

R1(config-router)#network 20.0.0.0

R1(config-router)#exit

R1(config)#do wr

Building configuration…

[OK]

R1(config)#

Проверим, а пакеты не идут 😦

Оказалось слетели Access порты на коммутаторе (глюки GNS3), поправил…

Теперь все работает как должно.

Всем хорошей работы!!!

 

 

25.06.2019 - Posted by | Network and Wi-fi: cisco, mikrotik, huawei, tp-link, d-link, zyxel и другое...

Sorry, the comment form is closed at this time.

%d такие блоггеры, как: