Blog of Khlebalin Dmitriy

(Дорогу осилит идущий…)

Фотоприколы (часть 335).

В минувшие выходные, первый раз в этом сезоне на роликах, пробежали 10 км, мягко сказать результат удручающий, сказывается 9 месячный перерыв в тренировках. Завтра хотели бежать 20-ку, но пару дней назад я поймал жесткую ангину, и ролики, как и силовые тренировки, автоматически «почили в бозе», хотя погода в Москве просто призывает к  забегу 😦

Но жизнь продолжается, придется все выходные просидеть за компом и что-нибудь изучить…

Традиционно по пятницам, подборка понравившихся мне картинок, на безграничных просторах интернета для поднятия настроения.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Всем хороших выходных!!!

07.06.2019 Posted by | фотоприколы... | Оставьте комментарий

Основные команды Mikrotik.

Так сложилось, что ранее мне вообще никогда не довелось работать с железом Mikrotik. Вскоре у нас начинается проект по интеграции Cisco с Mikrotik и на прошлой неделе к нам уже поступил первый роутер Mikrotik hEX PoE, довелось даже его немного покрутить, в этой связи начну постепенно просвещать себя и в этой области.

Думаю начать стоит с понимания командной строки и как обычно с основных команд… ну а далее Winbox в помощь.

Вот тут очень подробно написаны основы командной строки: http://mikrotik.vetriks.ru/wiki/%D0%94%D0%BB%D1%8F_%D0%BD%D0%B0%D1%87%D0%B8%D0%BD%D0%B0%D1%8E%D1%89%D0%B8%D1%85:%D0%9A%D0%BE%D0%BD%D1%81%D0%BE%D0%BB%D1%8C

Далее основные команды:

ПОЛЬЗОВАТЕЛИ.

Добавление пользователя:

use add name=user password=12345 group=full

Выйти:

Quit

Выключить пользователя:

user disable admin

Посмотреть пользователей:

user print

ИНТЕРФЕЙСЫ. 

Просмотр интерфейсов:

interface print

Отключить/Включить интерфейс:

interface set disabled=yes numbers=x

где x — # номер интерфейса из print

Назначение интерфейсу IP адреса:

ip address add address 10.0.0.1/24 interface ether1

Просмотр IP адресов:

ip address print

Изменение MTU интерфейсов:

interface set 0,1,2 mtu=1500

Установка шлюза по умолчанию:

ip route add gateway=10.0.0.100

Посмотреть ARP Table (show arp в cisco)

ip arp print

Посмотреть MAC Address Table (show mac address-table)

interface bridge host print

Изменение mac адреса интерфейса:

/interface ethernet set ether1 mac-address=00:00:00:00:00:00

Сброс mac адреса интерфейса:

/interface ethernet reset-mac ether1

Посмотреть ip routing table (show ip route в cisco)

ip route print

Посмотреть маршрут на определенный адрес (show ip route 10.0.0.100 в cisco)

ip route check 10.0.0.100

DNS.

Просмотр DNS параметров:

ip dns print

Устанавливаем первичный и вторичный адреса DNS серверов:

ip dns set primary-dns=192.168.10.3 secondary-dns=8.8.8.8 allow-remote-requests=yes

TIME.

Установка часового пояса:

system clock set time-zone=+3

Установка ip адреса ntp сервера с которым будет сверяться время (в моем текущем случае это контроллер PDC):

system ntp client set enabled=yes primary-ntp=192.168.10.3

Просмотр времени:

/system clock print

FIREWALL.

Закрываем внутреннюю сеть для WAN порта:

ip firewall nat add chain=srcnat action=masquerade out-interface=интерфейс провайдера

Просмотр правил:

ip firewall filter print

Ограничения количества соединений с одного IP:

/ip firewall rule forward add protocol=tcp tcp -options=syn-only connection-limit=10 action=drop

Блокировка всех TCP пакетов идущих на порт 135:

/ip firewall rule forward add dst -port=135 protocol=tcp action=drop

Проброс  80 порта наружу:

/ip firewall dst-nat add action=nat protocol=tcp dst-address=10.0.0.100/24:80 to-dst-address=внутренний адрес сервака

SYSTEM.

Посмотреть аптайм:

/system resource print 

Просмотр стандартных настроек:

/system default-configuration print

Сброс настроек:

/system reset-configuration

Просмотр истории:

/system history print

 

SERVICES.

Просмотр служб:

/ip service print

 

ROUTE.

Посмотреть OSPF Neighbour (show ip ospf neighbor в cisco)

/routing ospf neighbor print

 

COMМAND LINE.

Переход на уровень выше:

/

Выполнение команды из другого уровня без смены текущего:

/.

Помощь:

?

Настройка маршрутизатора с помощью мастера настроек:

setup

Пинг:

ping 10.0.0.100 count 3 size 512

Продолжение следует…

Всем хорошей работы!!!

06.06.2019 Posted by | Network and Wi-fi: cisco, mikrotik, huawei, tp-link, d-link, zyxel и другое... | 1 комментарий

VTP на Cisco.

Подробно про VTP читаем здесь: http://xgu.ru/wiki/VTP

Коротко, если лень создавать VLANы руками на каждом коммутаторе или коммутаторов много, то можно использовать VTP (VLAN Trunking Protocol).

Протокол VTP отвечает за распространение сведений о VLAN существующих на одних коммутаторах,  между  остальными коммутаторами определенной группы (такую группу коммутаторов называют VTP доменом) и это сильно упрощает процесс реконфигурации виртуальных локальных сетей на коммутаторах Cisco.

Все коммутаторы, на которых функционирует протокол VTP, могут работать в одном из трех режимов: сервер, клиент, прозрачный режим.

-Коммутаторы, работающие в режиме сервера, позволяют вносить изменения в конфигурацию VLAN на текущем коммутаторе, а так же способны распространять данную конфигурацию между другими  коммутаторами VTP домена, передавая данные о внесенных изменениях через магистральные порты.

-Коммутаторы, работающие в режиме клиента, способны принимать данные об изменениях в составе виртуальных локальных сетей отправленные коммутаторами, работающими в режиме VTPсерверов, и способны на основание этих данных перестраивать свои списки существующихVLAN.

-Коммутаторы работающие в прозрачном режиме пропускают через свои магистральные порты данные об изменение в конфигурации VLAN, но не применяют их по отношению к своей конфигурации VLAN.

Для примера небольшая схема:

Устройства имеют следующую конфигурацию:

Коммутатор Sw0:

Sw0(config)#interface range fastEthernet 0/1-2

Sw0(config-if-range)#switchport mode trunk

Коммутатор Sw1:

Sw1(config)#interface fastEthernet 0/1

Sw1(config-if)#switchport mode trunk

Коммутатор Sw2:

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#switchport mode trunk

#show interfaces trunk

В нашем случае в качестве VTP сервера удобно выбрать коммутатор Switch0 (Хотя если вам очень хочется можете выбрать любой другой). Для того чтобы сконфигурировать Switch0 в качестве VTP сервера выполним на нем следующие команды:

Switch(config)#vtp domain comp

Switch(config)#vtp password cisco

Switch(config)#vtp version 2

Далее сконфигурируем коммутаторы Switch1 и Switch2 в качестве клиентов VTP, для этого выполним на них команды:

Switch(config)#vtp domain comp

Switch(config)#vtp password cisco

Switch(config)#vtp version 2

Switch(config)#vtp mode client

После введения данных команд базовую конфигурацию нашего VTP домена можно считать законченной. Настало время проверить его работу. Для этого мы выполним на коммутатореSwitch0 команды:

 

Switch(config)#vlan 2

Switch(config-vlan)#name manage

#sh vlan brief

Всем хорошей работы!!!

05.06.2019 Posted by | Network and Wi-fi: cisco, mikrotik, huawei, tp-link, d-link, zyxel и другое... | Оставьте комментарий